Cloud Provider Issues

Incident Report for JENTIS Status Page

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 08:25 CEST

Monitoring

The fix has been implement and we are monitoring the results
Posted Jul 23, 2026 - 09:59 CEST

Identified

We have identified issues with one of our cloud providers which might cause degraded performance across our platform. We are currently working on resolving it as fast as possible
Posted Jul 23, 2026 - 09:58 CEST
This incident affected: Main (Stable) Account and Data Status (Platform Access (DCP), Data Capturing and Processing) and Beta Accounts (Invite Only) (Platform Access (DCP), Data Capturing and Processing).